your blog appears to be having relations with a canine

Ibm_pc-xt286_1Here’s the whole technical reason for the downtime.

An old Dell workstation (Dual P3 Xeon 550) functions as a VMWare GSX Server host. On that server lives four virtual servers: SQL Server, Web Server, Active Directory Server and Exchange Server. The hard-drive image files for the active directory server live on an IDE drive in an external firewire drive enclosure which has some bad sectors. 95% of the drive is fine, but the bad sectors currently hold some critical section of Windows that refuses to boot the AD server. I’ve had this same situation for the last year or so, but I’ve managed to get through it by clicking “continue” approximately 200 times until the error went away. But not this time. Exchange won’t start with the AD server down which is the real problem. If I had enough resources on the box I could keep the web sites up, but since I’m trying to fix this ASAP I need them free to rebuild everything.

I can’t copy off the virtual disk (.vmdk) files because Windows complains of CRC errors and refuses to continue. I can’t get chkdsk to run on the drive past 5% or so. I can’t use any of the boot-to disk checker tools because the drive is on a firewire interface and all the ones I’ve tried only work with IDE or SCSI. I can’t transplant the drive internally because it fails to be recognized by disk management when loaded into a new machine.

The VM machine won’t boot to safe mode. I can’t run a repair from the CD because it fails to even see the HD. Use easy recovery to recover the entire contents of c:\ and boot to the new one? nope, crashes.

I have a backup of the server, but it is old and I don’t think exchange will like being so out of sync. I tried restoring the backup to win2003, then realized the backup was for windows 2000. Restore from backup boots with “missing file errors” due to this page not being written well: support.microsoft.com/Q263532 — the “important, you must have DNS and SMTP Server installed on the new machine” is below the fold and I didn’t see it. Active Directory backups have a useful life of 60 days. A simple change the clock back to February 2003 fixed that problem.

I finally got the backup AD server up and running. I was all set to fire up Exchange and see what happened, but I decided, hey I haven’t a regular start of the old one in a while and a lot has happened since then, one last go…

What do ya know, it came up. I had accidentally left the virtual network card turned off. The box was up, but useless without network, so I had one final right click enable. Bingo. Up and running. Exchange came up fine, like nothing happened. I was then able to start the SQL Server and the IIS box. I still have those bad sectors, they haven’t gone anywhere, but I managed to trick it into booting.

Published

2 comments

  1. Actual conversation held 3/15:

    Corey: tech stuff tech stuff blah blah blah tech tech blah blah, so that’s why you’re blog was down. But blah blah blah tech tech tech blah blah tech and it amazingly came up!

    Hollie: "So, what you’re saying is you rebooted the machine"

    Corey: "Yeah"

Leave a Reply to Hollie Cancel reply

Your email address will not be published.